KB
Home > Help > Technical problems >  System requirements
Facebook Tweet Email Share

Main Content

Help

System requirements

Browsers and operating systems

Supported Operating Systems:

  • Apple: macOS, iOS
  • Google Android (Chrome OS is not currently supported)
  • Windows: 10, 8.1., 8, 7

Supported Browsers:

The latest version of each of the following browsers is supported, plus the 2 previous versions. If the current version of your operating system is unable to support the latest browsers, you will need to update your software.

Use the link provided to download the latest version of these browsers.


Software you might need (Plugins)

Some documents on this website are available as a PDF (xxxx.pdf). You need Adobe Acrobat Reader to open these files. You can download this program for free from Adobe. Check your computer to see if you already have this program before you download it (it is a large file).


Accessibility

Go to Top